General

Notice: Undefined index: tasklist_type in /home/antergos/bugs/includes/class.tpl.php(128) : eval()'d code on line 85 Notice: Undefined index: tasklist_type in /home/antergos/bugs/includes/class.tpl.php(128) : eval()'d code on line 90
  • Status New
  • Percent Complete
    0%
  • Task Type Bug
  • Category
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Normal
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: General
Opened by chris_debian (chris_debian) - 2013-05-15

FS#1 - Unable to Boot Past Failed Service, During Installation

Hi, all.

I recorded this problem in the forum [0], as at the time I was unable to open a bug.

[0] http://forum.antergos.com/viewtopic.php?f=5&t=937

Everything goes well until I get to one of the services which is trying to start, but fails. The error message I get is:

See 'systemctl status systemd-login.service' for details. Stopping login service

This repeats several times and then X starts and tells me that something has gone wrong and I have no other option than to reboot.

I am trying to install on a 32-bit machine, using the 32-bit 2013-05-12 torrent image.

I note that if I switch to a virtual terminal, I can log in to do 'antergos-setup', but this fails with a 'display' error, probably because X has started to give me the 'failed...log out' message.

It may help (i'm not sure) if I was able to do a CLI install, but this option doesn't seem to be available from the boot splash screen. On a positive note, I left the 32-bit installation DVD in my main 64-bit PC (after burning the image) and when I booted it this evening, it booted straight up to the Live/ CLI/ Graphical installer screen, and then succesfully entered the Live GNOME session. This suggests the ISO works correctly, so it is probably hardware related.

Any help appreciated.

Cheers,

Chris.

This task does not depend on any other tasks.

Alex Filgueira (faidoc)
Wednesday, 15 May 2013, 21:49 GMT
So the problem is that it doesn't boot on your 32bit pc but it does in your 64 right?
chris_debian (chris_debian)
Thursday, 16 May 2013, 11:30 GMT
Hi, Faidoc.

The problem is that the Login service fails, so that I am unable to get to the point where I can start the installer. This also happens with the later (test) ISO that you published the link for. I was using Manjaro, and now have Bridge installed. Is there a way to start an alternative installer, rather than getting this error message and then being told to reboot. I didn't see an option in the boot menu.

Cheers,

Chris.
Alex Filgueira (faidoc)
Thursday, 16 May 2013, 11:39 GMT
Weird :S

Could you send me some logs?

You can use "sudo journalctl -b -o cat > log.txt"

There's no other kind of installation, but you could try booting in maintenance mode writing a single "1" (no quotes) at the end of the boot command in the boot screen. Root has no password, then configure your network connection and launch "sh /arch/setup"
chris_debian (chris_debian)
Thursday, 16 May 2013, 12:32 GMT
faidoc, thanks for the quick reply.

I tried sudo journalctl -b -o cat > log.txt, but the output on the screen was unreadable, due to the monitor being poorly configured. I initially tried to log on as a normal user (antergos), but the passwd 'live' failed, perhaps a password isn't needed and the screen message is wrong. The root account does work, but as I say, I was unable to read the output.

I tried the single user mode, and initially forgot to set-up the internet and this resulted in a prompt telling me this. I hit the OK button, but the prompt kept reappearing, so I had to reboot.

When I tried again, the set-up process started, but I couldn't read the dialogue boxes, because the screen was misconfigured and corrupted.

I really appreciate you trying to help, but I may need to come back to Antergos when it has had a bit more time to mature. I have never had issues like this, and I don't expect the install to be this troublesome.

On the 'up side', the login service seemed to start this time, but GDM failed. I'm going to try some different media and see whether that is the problem. As i say though, it started fine in another PC.

Thanks, again.

Chris.
Keith Smiley (SmileyKeith)
Thursday, 24 October 2013, 14:48 GMT
I am experiencing this same bug. Here is a screenshot of the output I see before I am forced to restart my machine. http://cl.ly/S7ud
Alejandro Cobo (winniepei)
Friday, 08 November 2013, 13:21 GMT
Same issue here when trying to boot from Antergos cd, even not trying to install, only booting.

Could it be a problem related to GDM with Intel graphics card?
I remember installing ArchLinux months ago and had to change a setting to let Arch start despite my Intel graphics card.

Hope you can solve this soon, I would like to try (at least) Antergos.
Thanks.
Regards.
Aviad Raviv-Vash (aviad)
Friday, 08 November 2013, 21:09 GMT
Also being affected by this issue.
I've tried to boot on both a Dell E6420 and a Lenovo T520 with the exact problem as in the screenshot.

Loading...